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Safety Information \

Requirements

Intended Users

This Application Note is to be made available to all persons who are required to install,
configure or service equipment described herein, or any other associated operation.

The information given is intended to enable the user to obtain maximum benefit from the
equipment.

Application Area

The equipment described is intended for industrial motor speed control utilising AC induction or
AC synchronous machines.

Personnel

Installation, operation and maintenance of the equipment should be carried out by qualified
personnel. A qualified person is someone who is technically competent and familiar with all
safety information and established safety practices; with the installation process, operation and
maintenance of this equipment; and with all the hazards involved.

Hazards

Refer to the Safety Information given at the front of the Quick Start Manual supplied with every
Parker Hannifin Manufacturing UK Ltd product.



CO1 3 LANGUAGE FILES

Abstract

This application note explains how to create user language files on an AC30 drive.

Introduction

The AC30CustomLanguageManager utility, (Language Manager), allows the user to create alternative text for all the text
held in the drive, (predominantly the parameter & menu names). The Language Manager also allows the user to create
translations for new parameters created as part of the application. When loaded into the drive the alternative text is used on
the Graphical Key Pad, (GKP), and the drive’s web page.

Creating the Language Files

Obtaining the AC30CustomLanguageManager utility

The AC30CustomLanguageManager utility is available from the software downloads page on the parker.com web page.
Currently this is available at http://divapps.parker.com/divapps/eme/EME/downloads/EME_Software.htm.

Loading text for the standard parameters and menus

On opening the Language Manager for the first time it shows a mostly blank page as shown.

£ AC30 Custom Language Manager(Deskiop App) 1.8.00 =E—
File @ 0 ENGLISH ~ | L FRANCAIS -
String Id | Reference String | Translation AT
0000 0 0 Selected Items: 0

Under the “File” menu, select “Import Fixed Strings”. (To load the text from the drive it is necessary to have PDQ or PDD
installed on the PC.)
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Language Files v
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This will bring up the following dialog box. Click on the product corresponding to your AC30 drive then click on “Select”.
If the version required is not shown, click on “Show All Versions”.


http://divapps.parker.com/divapps/eme/EME/downloads/EME_Software.htm

-
£ Select your AC30 product type

= B [ |

[T Show Al Versions

Product Type Version
(~) AC30PNIO (Profinetl0)

;\CEOPNIC (ProfinetlO) 41811
~) AC30EIPS (EthernetIP)

AC30EIPS (EthernstP) 31811
~) AC30PD

AC30PD 21811
~) AC3OV

AC30V 11811

L

The Language Manager is now populated with all the text built into the drive firmware.

File G| 0 ENGLISH = | LFRANCAIS -
String Id | Reference String W | Translation V| =
0
1 FALSE
2 TRUE
3 Min
4 Max
5 PNO
6 UP/DOWN to Change Haut/Bas - changer
7 OKto Select CK pour sélectionner
8 DEFAULTS LOADED DEFAUT CHARGES
Q w TRIPPED #+or sk DECLENCHE #
10 User Parameters
11 * ALERT ™ ** ALERTE ™~ -
118110 0 Selected Items: 0

Loading text from the configuration

Use the PDQ or PDD configuration tool to transfer the text from the configuration to the Language Manager. Open the
configuration in PDQ, then select “Drive Customization” from the “Tools” menu. Drive Customization is also available in

PDD.
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This opens the “Soft Parameter Editor”. In this editor, select “Advanced” then “Export Repository”.



£ Soft Parameter Editor = | B |5
@ Edit Advanced |
Edit Del Tag Name Description Units Type Mapped Variable Alias View Write Format  Default Min Export Repository

;E_, 1900 Selected Application ENUM 109C 0 Import Repository

] 1901 RL Ramp Time Rate of change of the Qutput. Defined ¢ TIME raise_lower_L.Ramp_Time XX T#10s T#0s R

5 n X ., X _ . Regenerate SoftParameters

5 1902 RL Reset Value The value Qutput is set to when the Res % REAL raise_lower_1.Reset_Value XX 0 -500

= 1903 RL Maximum Value  The maximum value to which Outpu REAL raise_lower_1Maximum_Value XX 100 -500 Display LanguageModel
1904 RL Minimum Value  The minimum value to which Output REAL raise_lower_LMinimum_Value XX -100 -500 Clear All Walue Pointers
1905 Raise Lower Qutput  The ramp ocutput monitor. Output is pre % REAL raise_lower_1.Output XX 0 -500

T 1906 Minimum Speed Val Specifies the minimum output value, % REAL minimum_speed2_1.Minimum XX -100 -100

a 1907 Minimum Speed Mo  This is either proportional with minimu ENUM minimum_speed2_1.Mode 0

3 1008 Skip FreqBand 1 The wicth of skip band 1in Hz. Hz  REAL <kip_fraquencies_1.Band_1 XX 0 0 1

i 1909 Skip Frequency 1 The centre frequency of skipband Lin | Hz REAL skip_frequencies_LFrequency_1 XX 0 0 1

] 1990 Skip FregBand 2 The width of skip band 2 in Hz. Hz  REAL skip_frequencies_1.Band_2 XX 0 0 1

E 1011 Skip Frequency 2 The centre fraquency of skip band 2in | Hz  REAL <kip_fraquencies_LFrequency_2 XX 0 0 1

% 1912 Skip FregBand 3 The width of skip band 3 in Hz. Hz  REAL skip_frequencies_1.Band_3 XX 0 0 1

%_ 1913 Skip Frequency 3 The centre frequency of skip band 3in| Hz REAL skip_frequencies_L.Frequency_3 XX 0 0 1

2 1914 Skip FreqBand 4 The width of skip band 4 in Hz. Hz REAL skip_frequencies_L.Band_4 XX 0 0 1

— 1915 Skip Frequency4  The centre frequency of skipband 4in | Hz  REAL skip_frequencies_LFrequency 4 XX 0 0 1

1916 Preset Speed 0 Preset Speed Output when Selected Pr % REAL presets2_llnput 0 XX 0 -100

% 1917 PresetSpeed 1 Preset Speed Output when Selected Pr % REAL presets2_llnput 1 XX 0 -100

g 1918 Preset Speed 2 Preset Speed Output when Selected Pr - % REAL presets?_1Input_2 XX 0 -100

2 1010 Praset Speed 3 Preset Speed Output when Selectsd Pr % REAL presets2_1Input_3 XX 0 -100

% 1920 PresetSpeed 4 Preset Speed Output when Selected Pr % REAL presets2_llnput 4 XX 0 -100 .

—i < — = = = = = = = = n — = = ] b

% True True

The configuration text is exported as an xml file. Save this file in a suitable folder, then in the Language Manager select
“Import Drive Customization Strings” from the “File” menu.
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] AC30 Custom Language Manager{Desktop App) 1.80.0 o | B |l
File @/ 0 ENGLISH ~ |1 FRANCAIS =
Mew Language Project | Translation Y| =

11811 0 O

Selected Items: 0

Navigate to the file “Repository.xml” created in the previous step and open this file.

Project Files

At this point it is advisable to create a language file Project by selecting “Save language Project” from the “File” menu. The
Project file saves all the text imported into the Language Manager and can be used to back up your work.

Modifying an Existing Language

1 FRANCAIS v

% Reference String

v

‘ String Id

The Language Manager shows three columns, “String ID”, “Reference String” and “Translation”. To modify an existing
Language, select the required language using the drop-down list above the Translation column. To help find a string the
rows can be sorted by any of the three columns. When sorting by “String 1d” it is helpful to know that text contained in the
configuration is given an ID in the range 5000 and above. Text that is always in the drive has an ID less than 5000.

Enter the modified text in the Translation column in the appropriate row. If a row is left empty, then the text used will be
that from the English column.

Creating a new Language

To create a new Language, it is first necessary to give that language a name. Click on the o icon. This shows the text
shown for each language. For example, to create text for Turkish change “L 6 to “TURK”

Having created the language, select this as the Translation column and start entering the required translations.



T AC30 Custom Language Manager(Desktop App) 1.8.0.0 o

File All | @0 ENGLISH ~ |6 TURK

AR

Stingld | Reference String V| Translation
0
1 FALSE Yanls
2 TRUE Dogru
3 Min
4 Max
5 PNO
& UP/DOWN to Change
7 OKto Select
8 DEFAULTS LOADED
9+ TRIPPED =+

10 User Parameters -
11811 3901782024 3901792024 Selected Items: 1

Notes

e There are close to 2000 text strings in the drive. It is usually not necessary to translate all of these. Often it is only
necessary to provide translations for the top level menus and the parameters defined in the application, (with String IDs
in the 5000 range).

e Itis possible to “copy and paste” between the Language Manager and other applications such as Excel.

e The GKP can only show 21 characters in each line. If a string is longer than 21 characters it will be truncated on the
GKP. While the web page can show longer lines of text it should be noted that having just a few longer lines can
dramatically increase the size of a language file. This is due to the simple file format chosen to save the text in the
drive.

e Save the Language Manager project regularly when adding or modifying text to avoid loosing work in the case of a
problem. It can be a good practice to backup the Project file to a different folder or PC

Creating Language Files

To create the language files, select “Language Files” from the “File” menu. Choose whether to create all languages or just
the currently selected translation. The language files are named “language0.lang” to “language9.lang”. The files names
must be unchanged for the drive to recognise the translation.



Loading the Language files to the AC30

On the AC30V, language files must be saved on the SD card in a folder called “langfiles”. Only the “.lang” files need be
copied to the SD card, although it is possible to also save the project and repository files on the SD card for future
reference.

On the AC30P, AC30D & AC30A, the language files can be saved as above on an SD card. In addition, the language files
can be saved to the internal file store. If the files are saved to both locations the SD card takes precedence. To save the files
to the internal file use the AC30 file browser. This is built into PDQ and can be accessed from the PDQ start page under
Basic Operations, Open Project from Drive.

Basic Operations

=] Mew Project...
= Open Project...

Manuals, User Guide and Application Notes

In the left hand pane of the file browser select the required drive

£ AC30 Drive Services

L Drives Found ¢, | Proje
Drive [§ Type W 1P Address

AC30 000D46010C29  AC30V

& 000D46001084

ACI0P 000D460010B2  ACI0PD

In the right hand pane, select the “Drive File Browser” tab and ensure the “Internal Flash (C:)” volume is selected. (The SD
card is shown as volume A:).

| Project Archives | Drive File Browser | Drive Maintenance (Ethernet Settings and Firmware Install)

E AC30P 000048001082 & Internal Flash (&) | = * G
Mame Size Creation Date

archive.pr] 1463778 20/12/2018 15:59

Archive_l.pr 1466103 19/12/2018 10:14

Archive_2.prj 1378501 19/12/2018 10:10

If a langfiles folder does not already exist, create this by clicking on the ' icon. The folder must be called “langfiles”.
Enter the langfiles folder and click on “Browse” to transfer the language files to the drive. Space in the internal file store is
limited so it is not recommended to save the language Project file here.

Text in the AC30 and GKP

The Graphical Keypad, (GKP), is programmed with text corresponding to the parameters and menus that are always
present in the drive. The GKP contains this text in English, French, German, Spanish and Italian. To improve the
responsiveness of the display the GKP uses its local copy of the text when this available; however, the copy of the text in
the GKP is typically for an older version of firmware and may not contain text for newer or updated parameters. For these
parameters the GKP obtains the text from the drive firmware.

When the custom language is loaded into the drive the GKP is told to ignore its own copy and to use the text from the drive
for all parameters and menus. This check is only performed when the GKP is reset, so it may be necessary to unplug and
re-connect the GKP after updating a language file.



Trouble Shooting

Problem

Possible reason

No translations showing

e  Check the selected language
e  Check the language files are in a folder called langfiles.
e  Check the language files are named language0.lang to language9.lang.

e Ifusing an SD card, check the value of Parameters->Device Manager->
SD Card->Card State.

Web page only shows text in English,
the GKP shows text in the selected
language.

On the AC30V only English text is held in the drive. It is likely that the custom
language files have not been detected by the drive and the GKP is using a local
copy of the selected language text. Check the SD card and language files as
above.

New language shown as “L 6” to “L 9.

e Enter the text for the new language in the currently selected language.

e Force areset of the GKP by unplugging it.

Some translations will not show on the
GKP, (they show correctly on the web

page)

Some characters cannot be displayed on the GKP. If a text string contains an
unknown character, then it will not be shown on the GKP. This character
restriction does not apply to the web page.

Special Characters Supported by the GKP

Character Description Character Description Character Description
a a grave y y umlaut 0 O tilde
g e grave c ¢ cedille A A umlaut
i i grave R S sharpe E E umlaut
0 0 grave a a Nordic I | umlaut
u u grave § s Czech 0 O umlaut
a a acute z z Czech U U umlaut
é e acute A A grave Y Y umlaut
i i acute E E grave C C cedille
6 0 acute I | grave A A nordic
a u acute 0 O grave S S czech
y y acute U U grave Z Z czech
a a circumflex A A acute ¢ Cent
é e circumflex E E acute £ Pound currency
1 i circumflex i | acute ¥ Yen
0 o circumflex 0 O acute ° Degrees
0] u circumflex ¥] U acute * Plus / Minus
i a tilde Y Y acute u Micro
fi n tilde A A circumflex i ? inverted
0 o tilde E E circumflex i !'inverted
& a umlaut 1 | circumflex 2 2 superscript
é e umlaut 0 O circumflex 3 3 superscript
i i umlaut 8] U circumflex « Double chevron left
0 0 umlaut A Atilde » Double chevron right
i u umlaut N N tilde




